
2DBench
Open Cut Blast Design and Analysis

Tutorial

 Soft-Blast Pty Ltd  2011



JKSimBlast  -  2DBench

6/9/11 B-2

Screen Layout
1. Title Bar: stocks database,  design database,  design name / scenario
2. Menus: key shortcuts, Edit – mode specific, Tools – user definable

3. Toolbars: design modes,  mode tools,  global tools,  parameter summary

4. Design Area: limitless window,  scroll bars,  display options

5. Status Bar: mode,  action,  cursor E/N,  bearing & length (line, anchor),  window scale
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General Features
In these notes:

[click] = left click     [R-click] = right click     [click-click] = double click     [drag] = click and drag
[button] = left click the button     [key] = press the key     [key]+[key] = press both keys together

Design Modes

 Area draw and edit lines, polygons and point labels (collectively called ‘strings’)

 Hole create and edit blast holes and nodes

 Deck insert decks – explosive and inert

 Downhole insert down hole delays and boosters

 Surface connect holes and nodes with surface delays

 Detonation simulate detonation sequence and analyse timing

The first five design modes each represent a component of the blast and the data associated
with it.  The final mode, Detonation, calculates the blast timing during the simulation.

Toolbar

The first group of buttons on the toolbar are the design modes: Area (lines, polygons, labels),
Hole, Deck, Downhole Delays, Surface Delays, Detonate.  The next button is the global
parameter dialog – press this button in any design mode to display the parameter dialog for that
mode.  The remaining buttons are mode specific and global tools.  The parameters section on
the right displays a summary of the current parameters for the selected design mode.

Cursor
The mouse can act as a pointer or cursor.  To change to the cursor, move the mouse over the
Design Area and [click], [Enter] or [spacebar].  To exit, [R-click] or [spacebar].  You can move
the cursor with the mouse or the arrow keys.  Its position is shown by the coordinates on the
Status Bar. 2DBench constantly tracks the nearest object to the cursor.

Selection Box   and Mask
The selection box is a dashed rectangular box; the selection mask is a dashed multi-sided
shape.  Each is activated when its toolbar button is “on”.  The box and mask are used to mark
holes or zoom the viewing area.  To set the selection box, place the cursor at one corner of the
box, then [drag] the cursor to the position of the opposite corner.  For the mask, place the cursor
and [drag] for the first side, then [click] for each side – close by crossing the first side or [Esc].

To retain a box or mask, deactivate it (turn off) before activating the other.  Switching directly
from one to the other will convert it to the nearest approximation of the other.

 will create a mask to match the nearest line or polygon to the cursor.  Activate the button,
place the cursor near a line or polygon, and [click].  For a polygon, the mask will match the
polygon.  For a single straight line, the mask will be a rectangle at the east and north extents of
the line – if the line runs east/west or north/south, the mask will have a minimum width.

Zoom
[Z] to zoom in, [Shift]+[Z] to zoom out.  The screen will zoom to the box or mask if it is active,
otherwise zoom will double or halve the window scale, shown at the bottom-right corner.
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Blast Parameters
Blast parameters (hole and pattern dimensions, type and amount of explosives and delays, etc)
are entered via the parameters dialog.  Activate the dialog, enter the values, [Accept…], and
then create the blast components.  [Save] to write the parameters to an .ini file as default values
for future use, and [Recall] to recall the parameters.  [Close] to close the parameters dialog.

Global Tools
The global tools are available to use at anytime.
 selection [box] and [mask] to zoom the window or change hole marking
 [anchor] to measure distances from an object to the cursor or between objects (with [Home])
 [hook] to lock the cursor at a fixed distance from a line
 [query] to check data for objects
 [info] to check comments for objects
 [copy] to make an image copy of the design area

Marking
Selective actions, such as load, copy or delete, are performed on marked holes and nodes,
shown by a small M at the centre.  Mark or unmark holes via the >Selection menu, [M] / [U] to
mark / unmark the nearest hole to the cursor, or [Ctrl]+[M] / [Ctrl]+[U] to mark / unmark all holes.
The number of marked and total holes is shown in the summary bar. For example, mh 45/50
means 45 marked of a total of 50 holes and nodes.

Query (information display)
Click the information display button at any time to see all data for the selected object in the
current design mode (usually the nearest to the cursor).

Selecting Lines and Holes

>View >Line Visibility [I] = nearest line invisible   [Ctrl]+[I] = swap visibility

[M] / [U] mark / unmark nearest hole or node
[Ctrl]+[M]  [Ctrl]+[U] mark / unmark all holes and nodes  (in selection box or mask if on)
[Shift]+[S] swap marking

 [selection box] [drag] opposite corners

 [selection mask] [drag] first side,   [click] for next side,   etc.   up to 50 sides
[Esc] or cross first side to close

Note: - hole marking affects design actions, editing, analyses, export and reporting
- line visibility and hole marking properties are saved with the blast



JKSimBlast  -  2DBench

6/9/11 B-5

Tools and Keys

[   ] = key or button,  no [Shift] unless indicated

[click]  =  [Enter]

[click] or [Enter] or [space] activate the cursor in the Design Area

[R-click] or [space] exit Design Area

[R-click] activate window, no other action

redraw  [R] refresh screen

undo  [Alt]+[Bksp] one step back

goto  [click-click E/N] control cursor position:  absolute,  relative,  polar,  object
exit Design Area  >>  [Do Action]      use at any time

[Home] move cursor to nearest:  point on string  /  hole  /  surface delay

[End] centre all data (changes scale)

[Ctrl]+[End] centre screen at cursor (does not change scale)

[Z]  =  zoom [Z]   box / mask or half scale     [Shift]+[Z]   double scale
[Ctrl]+[Z]  previous view

[M] / [U]   +   [Ctrl] mark / unmark     nearest / all     holes and nodes

[I]    /    [Ctrl]+[I] nearest line invisible    /    swap visibility

[click-click scale] select / specify scale

 [parameters] click in any mode to define settings and object properties

 [anchor] place cursor, then [ ]  OR
[R-click] / [space] to exit and [anchor] then move cursor

 [hook] lock cursor at fixed distance from nearest line

 [query] info box:  nearest object to cursor, [click] object for multiple items
change mode while active,  highlight text and [R-click] to copy

 [comment] view comment information for blast, component and blastholes

 [picture] copy or save the Design Area as an image  = >File >Blast Image

[Backspace] delete nearest object: string  /  hole  /  top deck in nearest hole  /
top downhole delay in nearest hole  /  surface delay

[Delete] select objects to delete:  [mode]  decks  /  downhole  /  surface
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Save Blast

>File >Save Blast
>File >Save Blast As

A blast in 2DBench is made up of five
components, each representing the data
from the design modes.

A scenario is a combination of components
that make a single blast.  Scenarios 0 to 9
are reserved for pre-defined scenarios.
Each component can have an individual
name, but typically they have the same
name as the blast.  Each component has
an individual ID number in the database.

Save Blast As is automatically selected
when data is first saved for any component
of the blast.

It is advisable to save the blast regularly, as there is no temporary storage or auto save.

By default, blasts are saved to a MS Access database, with the extension .2db, based on the
template database file __BenchDesign.mdb.  The template includes the pre-defined scenarios.

[View] display the blast parameters for a selected blast (for replacement).  These are saved
from the Hole Parameters dialog.

To save a blast:

 Select the blast database  –  [Browse] to select a folder for the database, select or enter the
file name …for a new database,  [Yes] to create from the template.

 Enter a name for the blast.  The blast name will be automatically applied to the components,
otherwise click [Apply to All].  Each component can also have a different name if required.
Any character is allowed in a name, but it is advisable to not use \ / : * ? "  < > | & as these
may conflict with file handling routines in Windows.

 The check boxes in bold indicate which components will be saved – a component can be
forced to save or not save.

 Enter or select a scenario – 0 to 9 are pre-defined.  To save a new scenario (0 to 9) with the
same blast name, remove the ID number from each component names to create new data.

 Enter any comments, designer’s name, date and time of design or implementation.

 [Save]  -  the name of the database file and the blast will appear in the title bar.

To overwrite a previous design, select the name and scenario from the list and [Save].

suggestion: use a temporary database (e.g. default.2db) until the blast is complete, then
use Save As… to save the design to a permanent database.

The file ..\JKSimBlast\2DBench\data\default.2db can be deleted at any time and the program
will create a new one at the next start-up.
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Open Blast

>File >Open Blast

 select database, blast name, scenario

 [View] to display blast parameters

 check boxes can prevent loading of
components from selected blast

 components can be opened from different
blasts, as templates (by row / hole number)

>File >Add Blasts

 Same as Open Blast, but opens multiple blasts
(under the name of the first blast).

>File >Reload Current Blast

 Re-opens the current blast from the database, any changes are lost.

>File >Load Blast…

 The last five saved blasts are displayed in the File menu – [click] one to open.

Import

>File >Import >General String Import
>File >Import >General Hole Import

Lines, polygons and holes can be
imported from text files by the
DesignImport program.  This program is
activated from the File menu.

The minimum data format for the text file
is one point or hole per line, with E and N
coordinates.  Values must be separated
or in fixed width columns.

The import steps are:

1. select file, preview contents, define
data separator

2. select column names, check final
data  (hint: use Display Label for hole
labels or numbers)

3. filter data with exclusion criteria
4. enter default values for missing data,

set conversions for non-metric data
5. save the defined configuration and

defaults by name for later imports

Refer to the on-line help for detailed
information.



JKSimBlast  -  2DBench

6/9/11 B-8

Print

>File >Export >To Report…

The Report option exports the blast to a text file (lines,
labels, holes, nodes, decks, delays in the same format
as the Copy function) and an image file.  An Excel
workbook template (included with 2DBench) can
import the files and produce a formatted report.

1. Select the items to export:
- the data  are sent to a text file;
- the Design Area is saved as a bitmap file.

2. Select a folder and enter a file name
– the same name is used for both files, e.g. filename.txt and filename.bmp.

3. Choose an application to run with the exported data:
- defaults:  do nothing, open text file in editor, Excel template (if present in ..\Templates);
- custom applications can also be added (define in settings file 2DBench.ini).

4.  [Save] to store the above settings as defaults in 2DBench.ini for future use.  [Recall] to
retrieve saved settings.

5.  [Continue] to export the data and image, and open the selected application.  The file names
and folder path are written to the file ..\JKSimBlast\2DBench\RptFiles.ini.

In the Excel report template, select the menu option
>JKSimBlast >Get Report.

>File >Print Blast Window

Print the blast as it appears in the Design Area, at
scale, to fit paper size (different from screen size), on
any capable Windows printer.

Print Logo is an exact copy of bitmap file at:
..\JKSimBlast\AuxFiles\PrintLogo.bmp

Print can include contours and scales for detonation
contours, energy and PPV distributions, burden relief,
plus a simple text box.

[Preview] to see the result before printing.  Modify the
appearance and visibility of items in the Design Area
with the Print dialog open.

Settings
The settings include mode parameters, the appearance and colour of the Design Area and the
location and colour of text around the objects.  The settings are saved to an .ini file.  Any
number of files can be created.  Settings stored in 2DBench.ini are used as defaults at startup.

Parameters dialog = mode parameters >View >Display Options = Design Area appearance

>File >Preferences >Save All Settings to current .ini file
>File >Preferences >Save Settings As to selected .ini file
>File >Preferences >Recall Settings from selected .ini file

[Save] / [Recall] on dialogs  =  only values in the current dialog
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Tutorial
This tutorial will guide you through the steps to create a basic blast.
note:  global tools are available any time to assist in placing objects

[anchor] measure distance & bearing [hook] lock the cursor to a line
[Home] lock on the nearest object [End] center all objects on screen
[scroll] move the Design Area window GoTo move the cursor to a position or object
zoom zoom in [Z] or out [Shift]+[Z] or go to selection box or mask

Hole mode
For this example, you can use the default parameters to drill a hole pattern; however, if you
want to change them, activate the parameters dialog, enter new values and [Accept New
Values] then [Close].

o Select pattern drilling.

o Activate the cursor by placing the mouse over the Design Area and pressing the spacebar or
[click].  (To deactivate the cursor, press the [spacebar] or [R-click]).  Place the cursor high on
the left side of the screen for the location of the first hole (hole 1, row 1) and [click].

o Set the direction of the front row - move the cursor to the right.  The bearing of the row is
shown on the Status Bar - [click] to set the direction.

o Set the burden direction by moving the cursor below the front row line and [click].  The blast
pattern is created on the screen.

o Press [End] to center the design.

o Save the blast: >File >Save Blast will display >Save Blast As – select a folder and enter a
database name, enter a blast name and select a scenario, then [Save].

Place the cursor near any hole in the pattern, and click the [?] toolbar button to show
information on the hole.  Move the cursor to display a different hole.
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Area mode
This mode is for drawing lines and polygons and placing point labels in the blast (collectively
called strings).  These are mainly intended to “draw a picture” of the features around the blast
area, but can also be used to calculate areas and volumes, to control hole placement for some
drilling methods, and in the calculation of some analyses.

In this step, draw a polygon around the blast pattern to calculate the volume of the blast for the
design factors after the explosives have been loaded.

o Open the Area parameters and set the Level to the same as the Bench Level for the holes.

o Select the polygon tool on the toolbar.

o Place the cursor near one corner of the blast, and [click] to start the polygon.

o [Click] for each corner of the polygon, then cross over the first side and [click] to close.

o Save the blast >File >Save Blast, and select [Save] to accept the blast name, then [Yes] to
overwrite the previously saved holes.

Deck mode
Open the parameters dialog, and select a material – for the first deck, an explosive.  Click
[Show Details] to see the properties (note: non-explosives have VOD = 0).

o Select a quantity method for the amount of explosive to load, and enter an amount.  For a
single deck of explosives, select “Load to a Length from the Collar” and set the length at 5 m.

o Click [Accept New Values].  [Close] the parameters dialog if it is in the way.

o Select [Load all holes] on the toolbar.

o [Click] anywhere in the Design Area to load the deck of explosive in all of the holes.
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o In the parameters dialog, select a stemming and amount (“Load to a Length From the Collar”
and 0 metres), and [Accept…].  [Close] the parameters dialog.

o [Click] again in the Design Area to load the stemming.

o Click [?] on the toolbar to display details of the nearest hole.  [Click] on the hole to cycle
through the decks.  Click [?] again to close the query window.

o Save the blast: >File >Save Blast, then [Save] and [Yes].
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Design Factors

Now that the explosives have been loaded, you can
calculate the design factors to check if the blast conforms to
the design objectives.

There are two methods used to calculate design factors.
The first method uses a polygon and the defined bench
height to calculate a volume for the blast, and the second
uses the blast hole parameters to calculate a volume for
each hole.

The bench height is initially defined as the difference
between the bench level and floor level, defined in the hole
parameters.  The blast hole parameter method uses burden
and spacing and the vertical height of the blast hole, minus
subdrill, to calculate a volume for each hole.

In both cases, the total volume is multiplied by the defined
rock SG to calculate tonnage, and only marked holes are
used.  The bench height and SG values can be changed
directly on the dialog.

o First, mark all of the holes [Ctrl]+[M].
o Select >Analysis >Design Factors or press [F].

o [click-click] the Bench Height or Rock SG to change the values.

Downhole Delays

downhole delay = detonator, connector and booster

Open the parameters dialog, and select a downhole
delay (e.g. #20 / 500ms), connector (nonel) and primer
(booster).  Click [Show Details] to see the properties.

o On the [Delay] tab, enter a distance from the collar or
the toe for the delay to place the detonator at the
correct depth – the depth must be set so that the
delay is in the explosives deck (e.g. 1 m from toe) for
the detonation simulation to function correctly.

o Click [Accept] and [Close] the parameters dialog.

o Turn on the display for the number of delays in the
hole: >View >Display Options >Visibility >Num.
Downhole Delays in Hole

o Select [ALL holes] on the toolbar.

o [Click] anywhere in the Design Area to load the
delays in all of the blast holes.  You should see a
coloured triangle inside each hole.  To see the
detonator times or names, select >View >Display
Options >Visibility and select one or more of the text
items for downhole detonators.

o Click [?] on the toolbar to query any hole.
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o Save the blast: >File >Save Blast, then [Save] and [Yes].

Surface Delays

surface delay = detonator and connector

In this mode, you insert delays and connectors
between the blast holes.  For this example blast, tie a
simple pattern along the rows with a single centre line
between the rows.

o First, mark all of the holes.  In this mode, mark the
holes via the Marking menu, or [M] to mark the
nearest hole to the cursor.

o Open the parameters dialog, and select a
detonator and appropriate connector  (e.g. delay:
17ms;  connector: nonel).  Click [Show Details] to
see the properties. Note: in a custom stocks
database, the delay and connector colours are
both matched to the actual items.

o Select bi-directional (for this blast): typically, shock-
tube detonators are uni-directional; cord detonators
are bi-directional.  With bi-directional mode, it does
not matter which direction the delays are placed in
the blast.

o Select Inter-Hole for the delay type (this option
allows inter-hole and inter-row delays to be
displayed and edited separately – it does not affect
their performance).
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o [Accept] the values, and close the dialog.

o To display the delay times on the blast, select >View >Display Options >Visibility >InterHole
Actual Delay and …>InterRow Actual Delay.  Turn off the Visibility items from the previous
section.

o Select [Multiple hole tie up].   The holes must be marked for this method.

o Place the cursor on the first hole in the front row, and [click].

o Move the cursor slightly past the last hole in the row.  Note the highlighted holes are linked.
[Click] again to connect all of the marked holes with inter-hole delays.

o [Esc] to disconnect from the last hole (or [click] with the cursor still on the hole).

o Repeat for the other rows.

o If you make a mistake, place the cursor near the surface delay and press [Backspace], or
mark the relevant holes and select >Edit > Delete…

o Open the parameters dialog and select an inter-row delay and connector (e.g. 42ms).  Select
Inter-Row for the delay type.  [Accept] and [Close] the dialog.

o Select [Hole to Hole delay tie up].

o Place the cursor on a hole near the middle of the front row and [click].

o Place the cursor on a hole in the second row, and [click] again to connect the rows.

o Repeat for the third row and so on.  [Esc] or [click] on the last hole to disconnect.

o [?] on the toolbar to see the details for a delay.

o Save the blast: >File >Save Blast, then [Save] and [Yes].
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Detonation Simulation

In this mode you can run the detonation
simulation and calculate times for all items in
the design.  This is the last step in design, to
check that the timing is correct, and the first
major step in analysis.

You can open the parameters dialog if you
wish and modify any of the values, but the
default values will work fine for this example.

A normal, single simulation is based on scatter
properties as defined for each detonator.  To
run a simulation with only nominal times, set
the Scatter Multiplication Factors for both
surface and downhole to 0 (zero).

o To run the simulation, place the cursor over
the middle hole in the first row (where the
inter-row delay is connected) and [click].
You will see the surface delays initiating,
and then each hole detonating.

o The time during the simulation is displayed
at the bottom of the screen, over the Status
Bar.

o Press [S] at any time to stop the simulation.
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o Press any key to step through the simulation – e.g. [spacebar] – hold down the key to run
continuously until released.

o Press [C] to continue the simulation.

o To slow the simulation, enter a pause value in the parameters dialog (you will have to stop
and run it again).

o [Esc] stops the simulation completely.

o Re-run the simulation at any time by [click] to run the simulation from the previous initiation

point , or select  to run from a new point.

o Click [?] on the toolbar to query any hole.  This will display the detonation times for each
downhole and surface delay and deck of explosives.

o Save the blast: >File >Save Blast, then [Save] and [Yes]. This will add the detonation times
to the items in the blast components.

Basic Analyses

o Click   to calculate the first detonation time contours.  Open the parameters dialog and
the Contours tab to change the contour properties.

o Click   to display the Maximum Instantaneous Charge (MIC) chart to display detonation
times vs. charge mass, then click

  to change the window time and X-axis values;

  and then a bar to show the linked holes for that bar;

  to enter the values for the scaled-distance function;

  to display the PPV values for a selected bar.
o >Analysis >Blast Summary for totals … [Details] for more info … [Copy All] to export data


