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Disclaimer
JKSimBlast is a suite of powerful modular tools for the
simulation and management of blasting data. 2DBench,
2DRing, 2DFace, JKBMS, 2DView, TimeHEx, Design
Importer, StockView and Units are stand-alone modules of
JKSimBlast: 2DBench, 2DRing and 2DFace are used for
the design and editing of blasts in mining and related
applications; JKBMS is used to organize and display the
data associated with blasting; 2DView and TimeHEx are
extended analysis programs for JKSimBlast blasting data;
Design Importer imports data from text files directly to the
blast databases; StockView is for the storage of the
specifications of explosives and accessories; and Units is
for the management of user-defined systems of
measurement. As the program developers do not control
data creation, collection, analysis or interpretation, it is the
sole responsibility of the user to verify that input data are
accurate and appropriate, and that all conditions and
outputs are reasonable and comply with any statutory
requirements.
In no event will Soft-Blast or JKTech be liable for direct,
indirect, special, incidental or consequential damages
arising out of the use of or inability to use the software or
documentation.
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Introduction
Overview
JKSimBlast covers the design, editing, simulation, analysis Overview
and management of blasting in mining and related
operations. The main modules are 2DBench, 2DRing and
2DFace. These are graphical software programs for the
design and editing of blasts: 2DBench applies to bench
blasting in surface mines; 2DRing applies to underground
ring blasting; and 2DFace applies to underground tunneling
and development. The three programs give engineers and
blasting personnel the ability to design and optimise the
layout and initiation sequence of almost any type of blast
used in mining. Each allows the designer to:
layout a pattern of blastholes
load explosive decks and other materials in the holes
install downhole and surface delays, with primer and
connection details
simulate the detonation on screen
import and export data and print the blast
Individual elements of the blast are defined by the user,
including hole dimensions, explosives, delays, connectors
and boosters, and can be combined in a variety of blast
scenarios.

The design modules include detailed analysis tools to
calculate blast properties, summarise quantities and
consumables, and interpret blast performance. Other
modules in JKSimBlast provide for extended analysis of
blast layouts and energy (2DView, Energy and 2DContour)
and blast timing (TimeHEx).
Data management is
JKSimBlast
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provided by JKBMS (Blast Management System). Thus
JKSimBlast is a framework for a suite of programs for data
management in blasting, including design and simulation,
analysis, data collection and referencing, performance
evaluation, prediction and optimisation. Integration of the
modules is achieved through data sharing via Microsoft
Access databases. The open framework allows for other
third party applications to be developed and incorporated
into JKSimBlast, using the same databases for their own
purposes.
This approach provides the user with a
mechanism to maximise the use of the data.
This manual describes the basic and commonly used
features of the programs. More detail on JKSimBlast and
the modules is contained on the CD and in the various
sections of this manual, and in the on-line help with each
module.

Conventions
used in this
manual

Conventions
[click] click the left mouse button once
[double click]

click the left mouse button twice

[right click] click the right mouse button once
[drag]

click and hold the left mouse button, move the
mouse, then release the left mouse button

[…]

press the key, button or tab shown
do not press [Shift] unless indicated

[…]+[…]
>italic
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press the keys together

means a menu option
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Equipment Requirements
JKSimBlast runs on a personal computer under Microsoft Equipment
Windows 98 / NT4 / 2000 / XP.
The recommended Requirements
minimum requirements for running JKSimBlast are:
16 MB of random access memory (RAM)
CD disk drive (for installation)
hard disk drive with 65 MB of free space, plus 85 MB
of temporary free space for installation
SVGA graphics (800 x 600 display)
mouse
The installation program requires about 85 MB of free
space for the temporary installation files, which are
removed when the installation is completed. The full suite
of JKSimBlast program files occupy about 45 MB of disk
space, with a further 20 MB taken up by system files,
mostly in the Windows System folder. Some of these files
may be already present on the computer, so the final disk
space requirement may be less than that stated above.
Additional space will be required for blast database files
created by the user in the operation of the program.
All JKSimBlast modules are designed for SVGA graphics
(800 x 600 pixels). Although it will operate in VGA mode
(640 x 480), some of the items may be obscured or cut off
in the smaller screen area, such as dialog boxes, query
windows and status line messages.
JKSimBlast uses an electronic security key, which must be
attached to the computer before each module can run.
Additional and replacement keys can be obtained from
Soft-Blast.

JKSimBlast
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Software
Installation

Software Installation
Before proceeding:
For Windows NT, 2000 or XP, you may need
Administrator privileges for software installation.
JKSimBlast uses an electronic security key and a matching
license file as the license control for the software. You will
need both of these items to run the software.
Installing JKSimBlast
The installation program for JKSimBlast is used to install
any or all of the modules, plus the drivers for the electronic
security key. You have a choice to install either a complete
system for Surface Blasting or Underground Blasting, or
individual components (see the JKSimBlast overview on
the CD for more details).
You will need an appropriate license file to run the main
modules of JKSimBlast - JKBMS, 2DBench, 2DRing,
2DFace, 2DView, Energy, 2DContour and TimeHEx. This
file is supplied as part of the purchase of the software.
Instructions for installing the license file are at the end of
the section below. The utility modules StockView, Import
and Units do not require a security key or license file in
order to operate.
In the installation instructions, [disk]: refers to the drive
letter of your CD drive.
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1. Start the installation program
To install all of the modules in JKSimBlast, you will need
about 150MB of free space on your hard drive. This
includes 85MB of temporary space for the install program.
Installing only one module, such as 2DBench or 2DRing,
requires about 120MB.
To start the installation, run the program

[disk]:\install\JKSimBlast\Setup_JKSimBlast_v2.exe

Select [Open] or [Run from this location] if the program
does not start by itself. Alternatively, you can copy the
install program to a hard drive and run it from there.
Once the installation program starts, follow the on-screen
instructions.

2. Wait ...
The install program will create a temporary folder on your
hard drive to hold the extracted installation files. This is a
very large file, so it could take a few minutes. For example,
on a 500MHz computer running Windows 2000, the
extraction can take up to 1½ minutes. Please be patient.

JKSimBlast
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3. License Agreement
[Click] the button to accept the license agreement and
proceed. A copy of the license agreement is on the disk, in
the JKSimBlast install folder.
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4. Customer Information
Enter your name and organisation, if they are not already
shown. This is internal information only, for the operating
system.
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5. Destination Folder
Either accept the default installation folder, or click
[Change] to select a new folder.
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6. Setup Type
Select the type of installation:
o option 1: JKSimBlast for Surface Blasting
o option 2: JKSimBlast for Underground Blasting
o option 3: custom setup for all others, including
JKSimBlast for Tunnel Blasting

JKSimBlast
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7. Custom Setup
Use the Custom Setup to install individual components.
Note that the components StockView, Import and Units are
always installed.
To install JKSimBlast for Tunnel Blasting, select the
components 2DFace, TimeHEx, 2DView and JKBMS.
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Select how and when to install each component - typically,
always select the first option ...

JKSimBlast
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For example, to install only 2DBench, the screen should
look like this ...
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8. Ready to install
The software is now ready to install. Check the details, and
click [Install] to continue.

JKSimBlast
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Electronic
Security Key

Electronic Security Key
All of the main JKSimBlast modules require an electronic
security key to operate. The drivers for running either a
USB key or an LPT key (for the parallel printer port) are
installed with the program.
The Hardlock drivers can also be installed independently, if
required, by running the program hldrv32.exe from the
Hardlock folder on the CD.

License File

License File
To complete the installation, copy the license file
license.nfo to the main JKSimBlast folder (typically
C:\Program Files\JKSimBlast). The license file contains
details of the modules that are permitted to run with
each electronic security key.
The license file should either be on the CD in the
JKSimBlast folder, or supplied by email as an attachment.
If you do not have a license file, contact Soft-Blast.
Include the name of your organisation, contact person and
the serial number of your electronic security key.
Once the license file is in place, plug in the security key
and start the software.
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Fast Program Start
The programs JKBMS, 2DBench, 2DRing and 2DFace Fast Program
may take a long time to start at the first run, but should start Start
almost immediately on subsequent runs. At the first run,
the programs search internally for details of the electronic
security key.
These details are then stored in an
initialisation file in the program folder, and are used in
subsequent runs to enable faster start-up.
If a program does take a long time to start, a fast start can
be forced by modifying the shortcut to the program. Select
>Help >About, and note the code in square brackets at the
bottom of the form, e.g. [G123]. [Right click] on any
shortcut for starting the program (including the Start
menu), and select Properties from the pop-up menu. At the
end of the Target line, add /local=G123. For example:
"C:\Program Files\JKSim…2DBench.exe" /local=G123

Close the Properties, then restart the program from the
shortcut. It should start almost immediately.
For a network license, the code is in the form [Nnnn], and
the startup command is /net=Nnnn.

JKSimBlast
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Overview
2DBench is a graphical program for the design and analysis
of blasts in benching operations, typically for open cut
mines and quarries.

Overview

The blast is laid out in a 2D plan view, consisting of blast
holes, decks, and downhole and surface delays and
connections. The blast area can be further described by
lines, polygons and labels (collectively known as strings).
Both strings and blast holes can be imported from text files,
either as designs or actual data.
Once the blast layout is complete, a detonation simulation
can be run on-screen. Basic analyses include volume,
tonnage, powder factor, component and total costs and first
detonation contours. Advanced analyses include maximum
instantaneous charge, energy distribution, PPV contours,
dynamic burden relief, and fragmentation.
Although the blast is viewed in 2D plan, all data is created
and stored with full 3D coordinates (east, north, level) in
Microsoft Access databases. Added to this are component
details (hole parameters of dip, bearing, diameter, length,
burden, spacing), properties of explosives, detonators,
primers and connectors, and Monte Carlo detonation timing
information.
The data from 2DBench can be further analysed in 2DView
(in section and oblique views) for contouring of holerelated data and energy distribution and in TimeHEx (blast
timing vs holes and explosives) for arrival times and
cumulative effect. 2DBench blasts and any related data can
be organized and viewed in JKBMS (Blast Management
System).
JKSimBlast
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Appearance

Appearance
1. title bar
stocks database, blast database, blast name / scenario
2. menus
display, selection, tools, options, shortcuts
>Edit – mode specific, >Tools – user definable
3. toolbars
design modes, mode tools, global tools, parameter
summary
4. design area
limitless window, scroll bars, view options
5. status bar
mode, action, cursor E/N, bearing & length (line,
anchor), view scale
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Design Modes
Design Modes
A blast is divided into five components, created in the
various modes in the program. Each mode has specific
tools and functions, plus there are several other tools for
global editing, query, input and output functions.

Area draw and edit lines and polygons (called
‘strings’), text labels
Drill drill and edit blast holes and nodes
Load insert decks – explosive and inert
Downhole

insert down hole delays and boosters

Surface insert delays between holes and nodes
Detonation simulate detonation and analyse timing

General Features
General

Toolbar
Features
The first group of buttons on the toolbar are the blast
modes: Area (lines, polygons, labels), Drill, Load,
Downhole Delays, Surface Delays, and Detonation
Simulation. The next button is the global parameter dialog
– press this button in any mode to display the parameters
dialog for that mode. The remaining buttons are tools for
the selected mode tools and global tools. The last section is
a summary of the parameters in the selected mode.

JKSimBlast

19

2DBench

Cursor
The mouse can act as a pointer or cursor. To change to the
cursor, put the mouse over the Design Area and [click],
[Enter] or [spacebar]. To exit, [right-click] or [spacebar].
You can move the cursor with the mouse or the arrow keys.
Its position is shown by the coordinates on the status bar.
Selection Box / Mask
The selection box is a rectangular box; the selection mask
is a multi-sided shape. Either is enabled when the toolbar
button is “on”. The box and mask are used to mark holes
or zoom in on the viewing area. To set the selection box,
place the cursor for one corner of the box, then [drag] the
cursor to the position of the opposite corner. For the mask,
place the cursor and [drag] for the first side, then [click] for
each side – close by crossing the first side or [Esc].
Zoom
You can zoom in by pressing [Z] - zoom out by
[Shift]+[Z]. The screen will zoom to the box or mask if it
is active, otherwise zoom in or out will double or halve the
window scale. The scale is shown at the bottom of the
screen. [Double-click] the scale to activate a zoom control
box.
Blast Parameters
Blast parameters (hole and pattern dimensions, type and
amount of explosives and delays, etc) are entered via the
parameters dialog. Activate the dialog, enter the values,
click [Accept], and create the blast. Click [Save] to write
the parameters to an .ini file, and [Recall] to recall the
parameters. Click [Close] to close the parameters dialog.
Marking
Selective actions, such as load, copy or delete, are
performed on marked holes and nodes, shown by a small M
20
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in the centre of the hole. Mark or unmark holes via the
>Selection menu, [M] / [U] to mark / unmark the nearest
hole to the cursor, or [Ctrl]+[M] / [Ctrl]+[U] to mark /
unmark all holes. The number of marked and total holes is
shown in the summary bar (e.g. mh 45/50).
Query (information display)
[Click] the information display button at any time to see all
data for the current mode on the selected object (usually the
nearest to the cursor).
Help
Help is available from the >Help menu, or by clicking the
[Help] button on the dialogs.
Sample Blasts
Several sample blasts are included with the program in a
single 2DBench database, called samples.2db. These blasts
can be opened, viewed and modified in the program. The
sample database file is located in the data sub-folder,
typically in C:\Program Files\JKSimBlast\2DBench\data.
To open a sample blast, select >File >Open Blast… to
display the Open dialog. Click the [Browse] button, and
select the samples.2db file from the data folder. Then
select a blast from the [Name] list, and a scenario number
from the [Scenario] list if one is not selected automatically.
Click the [Open] button to open the blast in 2DBench.

JKSimBlast
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Tools & Keys

Tools & Keys
[click] = [Enter]
[click] or [Enter] or [space] = enter design area
[right-click] or [space] = exit design area
[right-click] = activate window, no other action
[R] Redraw = refresh screen
[Alt+Bksp] Undo = one step back
[click-click E/N] GoTo absolute, relative, polar, object
[Do Action]
use at any time
[Home] = move cursor to: nearest point on string, nearest
hole, nearest surface delay
[End] = centre all data (changes scale)
[Ctrl+End] = centre screen at cursor (does not change
scale)
= [anchor]

[right-click] or [space] to exit, [anchor]
OR place cursor, then [ ]

*

= [copy picture] set scale, window and view options
(also /File /Save Design Region Picture)
[Backspace] = delete nearest object: string, hole, top deck
in nearest hole, top D/H delay in nearest
hole, surface tie
[Delete] = select objects to delete: decks, D/H delays,
surface delays
22

JKSimBlast

2DBench

JKSimBlast

23

2DBench

24

JKSimBlast

2DBench Tutorial
Creating a Blast Design
This tutorial will take you through the basic steps for Creating a
Blast Design
creating a blast design in 2DBench.
Generally, you create a blast by working through each of
the modes, represented by the first six buttons on the
toolbar, from left to right. In each mode, several specific
tools are available for creating objects on the screen or
analysing the data associated with the objects. In almost all
cases, the actions defined by the tools are implemented by
either [click] on the desired object, or anywhere in the
design area for global actions.

Lines , Polygons and Labels

This mode is for creating strings: lines, polygons and point Lines,
labels. These are mainly intended to “draw a picture” of Polygons
the features around a blast, although both lines and & Labels
polygons can be used for hole layout, and polygons can be

used to calculate powder factors. Strings can also be
imported from text files, via the menu option >File
>Import. It is not compulsory to create strings for a blast,
so this will be ignored for this tutorial. Consult the on-line
help for details on how to create or import lines, polygons
and labels.

Drilling Holes

[Click] the Hole Drilling mode button on the toolbar Drill Holes
(second from left).

JKSimBlast
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There are several drilling methods: single hole, pattern,
polygon fill, follow line, and Baseline (from the Tools
menu). You can also place nodes (dummy holes) for
connecting surface delays where there is no blast hole. A
node is placed in the same manner as a single hole.
For this example, you can use the default parameters to
drill holes or patterns; however, if you want to change
them, activate the parameters dialog, enter new values and
click [Accept New Values] then [Close].
1. Select pattern drilling.
2. Place the cursor on the left side of the screen for the
location of the first hole (row 1, hole 1) and [click].
3. Set the direction of the front row - move the cursor to
the right. The bearing of the row is shown on the status
bar. [Click] to set the direction.
4. Set the burden direction by moving the cursor below the
front row line and [click]. The blast pattern is created
on the screen. (The same technique can be used to set
the pattern from the back row – note the [Burden
Direction] in the parameters.)
5. Press [End] to centre the blast on the screen.
6. Place the cursor near any hole in the pattern, and [click]
the query toolbar button [ ?] to show information on
the hole. Move the cursor to display a different hole.
7. Single holes and nodes can be placed anywhere in the
blast by placing the cursor and [click]. Nodes have the
same Bench Level as blast holes.
NOTE: by default, drilled holes are Unmarked and
imported holes are Marked.
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Saving the blas t

It is advisable to save the blast regularly. Blasts are saved Save the Blast
in a MS Access database. One database can hold multiple
blasts.
Select >File > Save Blast in the menu.

Click [Browse] and select a folder for the blast database.
Enter a new file name for the database (e.g. “tutorial”) and
click [Open]. Click [Yes] to create a new database called
“tutorial.2db”. New databases are created from a template
database stored in the Templates folder.
Enter a name for the blast. Select a pre-defined scenario
number or accept –(new)- to automatically generate a
number (10 or higher).
Click [Save]. The name of the database file and the blast
will appear in the title bar at the top of the screen. The
blast name includes the scenario number.
JKSimBlast
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Loading Decks

Load Decks

Select Material Loading mode (third button). Materials are
explosives and non-explosives.

Open the parameters dialog, and select a material – in this
case, an explosive. Click [Show Details] to see the
properties (note: non-explosives have VOD = 0).
Select a quantity method for the amount of explosive to
load, and enter an amount. For a deck loaded to x metres
from the collar, select [Load to a Length From the Collar]
and enter the length below.
Click [Accept New Values]. [Close] the parameters dialog
if it is obstructing the blast.
Select [Load all holes] on the toolbar.
[Click] anywhere in the design area to load the type and
amount of explosive in all of the blast holes.
In the parameters dialog, select a stemming material and
amount ([Load to a Length From the Collar] and 0 metres),
and [Accept…]. [Close] the parameters dialog.
[Click] again in the design area to load the stemming.
Click [ ?] on the toolbar to display details of the nearest
hole. [Click] on the hole again or [Page Up / Page Down]
to cycle through the charge details.
>File >Save Blast and [Save].
holes.
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Downhole Delays

Select Downhole Delay mode (fourth button). In this Downhole
mode, you insert delays, connectors and primers in the blast Delays
holes.

Open the parameters dialog, and select a downhole delay
(e.g. #20 / 500ms), connector (tube) and primer (any).
Click [Show Details] to see the properties.
On the [Delay] tab, enter a distance from the collar or the
toe for the delay – the depth must be set so that the delay is
in the explosive deck (e.g. 1 m from toe).
Click [Accept] and [Close] the parameters dialog.
Select [ALL holes] on the toolbar.
[Click] anywhere in the design area to load the delays in all
of the blast holes. You should see a coloured triangle
inside each hole.
Click [ ?] on the toolbar to query any hole.
>File >Save Blast and [Save]. [Yes] to overwrite the holes
and decks.

Surface Delays

Select Surface Delay mode (fifth button). In this mode, Surface
Delays
you insert delays and connectors between the blast holes.

JKSimBlast
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For this sample blast, tie a simple pattern along the rows
with a single centre line between the rows.
First, mark all of the holes. In this mode, mark the holes
via the Selection menu, or [Ctrl]+[M] with the cursor
inactive.
Open the parameters dialog, and select a detonator and
appropriate connector (e.g delay: 17ms; connector: 17).
Click [Show Details] to see the properties.
Select bi-directional (for this blast): typically, shock-tube
detonators are uni-directional; cord detonators are bidirectional. With bi-directional mode, it does not matter
which direction the delays are placed in the blast.
Select Inter-Hole for the delay type (this option allows
inter-hole and inter-row delays to be displayed separately –
it does not affect their performance).
[Accept] the values, and close the dialog.
Select [Multiple hole tie up].
marked for this method.

The holes must be

Place the cursor on the first hole in the front row, and
[click].
Move the cursor slightly past the last hole in the row. Note
the highlighted holes will be connected. [Click] again to
connect all of the marked holes with inter-hole delays.
[Esc] to disconnect from the last hole (or [click] with the
cursor on the hole).
Repeat for the other rows.
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If you make a mistake, place the cursor near a surface delay
and press [Backspace], or mark the relevant holes and
select >Edit >Delete…
Open the parameters dialog and select an inter-row delay
and connector (e.g. 42ms). Select Inter-Row for the delay
type. [Accept] and [Close] the dialog.
Select [Hole to Hole delay tie up].
Place the cursor on a hole near the middle of the front row
and [click].
Place the cursor on a hole in the second row, and [click]
again to connect the rows.
Repeat for the third row and so on. [Esc] or [click] on the
last hole to disconnect.
Click [ ?] on the toolbar to see the details for a delay.
>File >Save Blast and [Save] – [Yes].

Detonation Simulation

Select Detonation Simulation mode (sixth button). In this Detonation
mode, you run the detonation simulation and calculate Simulation
times for all objects in the blast.

You can open the parameters dialog if you wish and
modify any of the values, but the default values will work
fine for this example.

JKSimBlast
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To run the simulation, place the cursor over the middle hole
in the first row (where the inter-row delay is connected)
and [click]. You will see the surface delays initiating, and
then each hole detonating.
While the simulation is running…
[S]
= stop
[any key] = step
[C]
= continue
[Esc]
= end
To slow the simulation, enter a pause value in the
parameters. Click [ ?] on the toolbar to query a hole.
[Click] anywhere in the Design Areato run the simulation
again from the initiation hole, or select
simulation from the nearest hole to the cursor.

to run the

>File >Save Blast and [Save] – [Yes] to save the
detonation times with the blast.

Bas ic Analys es

Basic
Analyses

Click

to display the first detonation contours.

Click
to show a chart of maximum instantaneous
charges (kg per 8ms delay, initial setting). The time
window can be varied to any value. Click [ ?] on the
toolbar and then [click] any bar in the chart to see the
linked holes. Use the arrow keys to “scroll” through the
chart.
To display the detonation times, select >View >Display
Options, then [Visibility] – [Downhole Detonation Delay
Labels] and [Apply].
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Select >Analysis >Blast Summary for totals, counts and
averages of drilling, charging and delays used in the blast.
The details from these forms can be copied to the clipboard
and pasted into almost any application that can accept text.
Select >Analysis >Design Factors for the powder and
energy factors for the blast. First, mark the holes you wish
to calculate, then select one of the tabs on the dialog for the
different calculation methods. (Note: for the polygon
method, you need a polygon surrounding the blast to
approximate the area broken, and you must enter the
correct bench height.) You can enter the rock SG in the
form.
Select >File >Print Blast Window to print the blast plan,
and set the display via >View >Display Options.
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